We have Started Supporting Microsoft Edge

For people who are using Windows OS. About the browsers which Questetra BPM Suite is supporting.

We would like to announce that the System Requirements for Windows OS have been changed upon the release of Version 10.4.2 on January 18th, 2016.

Windows OS Supported browsers and its version(*)
Windows 7 SP2 (32/64bit)
Windows 8.1 (32/64bit)
Internet Explorer 9
Windows Vista SP2 (32bit) Internet Explorer 11
Windows 10 (32bit) Microsoft Edge 25

(*) Latest Stable Version as of Jan. 18th, 2016.

For the most up-to-date list of supported softwares, please check the System Requirements.

== 1. Can I use in Microsoft Edge? ==

We have added the new Windows 10 browser, Microsoft Edge, to Supported!

Although only Chrome / Firefox were supported for Windows 10 and earlier versions, it is now possible to use Questetra on Microsoft Edge from version 10.4.2 onwards.

workflow-ui-via-windows-edge

[Workflow] screen

enterprise-social-ui-via-windows-edge

[Open Chat] screen

However, unfortunately, the [Process Model Setting] function, which is a Workflow designer function, is out of scope at the moment. Partly, because it does not behave properly, but we are working hard to solve this issue. Please bare with us.

If you need to use the [Process Model Setting] function on a Windows 10 machine, please use Chrome / Firefox, instead.

== 2. Which version of Internet Explorer is supported? ==

On January 12, 2016 (US time), the support policy of Internet Explorer has been changed by the Microsoft Corporation. Thereby, it is decided that only the most recent version of Internet Explorer available for a supported operating system will receive technical support and security updates.

Stay up-to-date with Internet Explorer (IE Blog, Microsoft)

 

Together with Microsoft’s support policy changes, the Questetra’s System Requirements (supported) were changed into “Supports only the most recent version of Internet Explorer available for a supported Windows Operating System“.

Regarding Chrome / Firefox, we have been supporting the “latest stable version” so far, related to the response to security threats on the Internet. Hereafter, we are going to support the “latest stable version” of Internet Explorer / Edge.

Please use the Internet and Questetra safely and conveniently by using the latest browser versions!

 


Related Information
System Requirements
Stay up-to-date with Internet Explorer (IE Blog, Microsoft)

 

About Questetra Support

Questetra Support Team - Response within 24 hours
View all posts by Questetra Support

Recommendations
Prev article - 50. Questetra Tips Check Digest of Business with Internal Chat Service "slack"
Next article - 50. Questetra Tips Collaboration of Cloud-based Workflow with Various Groupwares
Another article - Questetra Support FAQ. Can I Modify Data Later on for Mis-Input, etc.?

Archive

 RSS